【poj2229】Sumsets

【poj2229】Sumsets

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6
题意:求一个数分解成2的幂次方的数相加的方案数

递推求解

对于每一个i

如果i为奇数:那么它一定可以由f[i-1]转移过来,是前面的那个数所有方案里都加了一个1

如果i为偶数:它可以看成是f[i-2]中的方案加了一个2,或者是f[i/2]的方案里乘了一个2;所以应该是f[i-2]和f[i/2]的和

【代码】

#include<iostream>
#include<cstring>
#include<cstdio>
#define p 1000000000
using namespace std;
int f[1000005];
int n;
int main(){
	scanf("%d",&n);
	f[1]=1;
	f[2]=2;
	for (int i=3;i<=n;++i)
	  if (i&1)
	    f[i]=f[i-1]%p;
	  else
	    f[i]=(f[i-2]+f[i/2])%p;
	printf("%d",f[n]);
}


你可能感兴趣的:(dp)