2004

2004

Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.<br>We all like toxophily.<br><br>Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?<br><br>Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m. <br>
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.<br>Technical Specification<br><br>1. T ≤ 100.<br>2. 0 ≤ x, y, v ≤ 10000. <br>
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.<br>Output "-1", if there's no possible answer.<br><br>Please use radian as unit. <br>
 

Sample Input
   
   
   
   
3<br>0.222018 23.901887 121.909183<br>39.096669 110.210922 20.270030<br>138.355025 2028.716904 25.079551<br>
 

Sample Output
   
   
   
   
1.561582<br>-1<br>-1<br>
 

Source
The 4th Baidu Cup final
 



思路:二分法+三分法;
       首先,使用三分法,分出一个角度让抛物线在x=x0时y取得最大值。  
       然后,再对y使用二分法找到一个合适的值;

AC代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
#define PI acos(-1.0)
#define G 9.8
#define eps 1e-12


using namespace std;


double X,Y,v,sita;


double cal(double x)
{
    double t;
    t=X/(v*cos(x));
    return v*sin(x)*t-0.5*G*t*t;
}


double triplediv()
{
    int i;
    double mid1,mid2,left,right,h1,h2;
    left=0,right=0.5*PI;
    for(i=1;i<=100;i++)
    {
        mid1=(2*left+right)/3;
        mid2=(left+2*right)/3;
        h1=cal(mid1);
        h2=cal(mid2);
        if(h1>h2)
        {
            right=mid2;
        }
        else
        {
            left=mid1;
        }
    }
    sita=left;
    return cal(left);
}


void doublediv(double maxy)
{
    int i;
    double left,right,mid,h;
    left=0,right=sita;
    for(i=1;i<=100;i++)
    {
        mid=(left+right)/2;
        h=cal(mid);
        if(h>Y)
            right=mid;
        else
            left=mid;
    }
    printf("%.6lf\n",left);
}


int main()
{
    int t;
    double maxy;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf",&X,&Y,&v);
        maxy=triplediv();
        if(maxy<Y)
            printf("-1\n");
        else
            doublediv(maxy);
    }
    return 0;
}

你可能感兴趣的:(2004)