hdu2602-Bone Collector (背包)

 Bone Collector

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input

      
      
      
      
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

      
      
      
      
14

背包dp的基础题,拿来熟悉基本公式。
#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
#define Max 200005

int dp[1005][1005];
int x[1005],y[1005];

int main(){
    int t,n,v;
    cin>>t;
    while (t--) {
        cin>>n>>v;
        for (int i=1; i<=n; i++) {
            cin>>x[i];
        }
        for (int i=1; i<=n; i++) {
            cin>>y[i];
        }
        memset(dp, 0, sizeof(dp));
        for (int i=1; i<=n; i++) {
            for (int j=0; j<=v; j++) {
                if (j>=y[i]) {
                    dp[i][j]=max(dp[i-1][j-y[i]]+x[i],dp[i-1][j]);
                }
                else dp[i][j]=dp[i-1][j];
            }
        }
        cout<<dp[n][v]<<endl;
    }
}

你可能感兴趣的:(hdu2602-Bone Collector (背包))