1339 - Ancient Cipher

Ancient Cipher

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher.

Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from ‘A’ to ‘Y’ to the next ones in the alphabet, and changes ‘Z’ to ‘A’, to the message “VICTORIOUS” one gets the message “WJDUPSJPVT”.

Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation(2;1;5;4;3;7;6;10;9;8)to the message “VICTORIOUS” one gets the message “IVOTCIRSUO”.

It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were rst encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message “VICTORIOUS” with the combination of the ciphers described above one gets the message “JWPUDJSTVP”.

Archeologists have recently found the message engraved on a stone plate. At the rst glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

Input
Input le contains several test cases. Each of them consists of two lines. The rst line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the rst line. It also contains only capital letters of the English alphabet.

The lengths of both lines of the input le are equal and do not exceed 100.

Output
For each test case, print one output line. Output “YES” if the message on the first line of the input le could be the result of encrypting the message on the second line, or “NO” in the other case.

Sample Input

JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES

Sample Output

YES
NO
YES
YES
NO

给定两个长度相同且不超过100的字符串,判断是否能把其中一个字符串的各个字母重排,然后对26个字母做一个一一映射,使得两个字符串相同。例如,JWPUDJSTVP重排后可以得到WJDUPSJPVT,然后把每个字母映射到它前一个字母(B->A, C->B, …, Z->Y, A->Z),得到VICTORIOUS。输入两个字符串,输出YES或者NO。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define maxNum 105

int cmp(const void *a, const void *b) {
    return *(int *)a - *(int *)b;
}

// 本题重点在于字母出现次数,而不是出现位置
int main() {
    // A加密串,B猜测串
    char A[maxNum], B[maxNum];
    while(scanf("%s%s", A, B) != EOF) {
        int n = strlen(A);
        int m = strlen(B);
        if(n != m) {
            printf("NO\n");
            continue;
        }
        // A,B中各个字母出现的次数
        int numA[26], numB[26];
        memset(numA, 0, sizeof(numA));
        memset(numB, 0, sizeof(numB));
        for(int i = 0; i < 26; i++){
            for(int j = 0; j < n; j++) {
                int na = A[j] - 'A';
                int nb = B[j] - 'A';
                numA[na]++;
                numB[nb]++;
            }
        }
        // 排序
        qsort(numA, 26, sizeof(int), cmp);
        qsort(numB, 26, sizeof(int), cmp);
        bool flag = true;
        // 判断字母出现次数是否相同
        for(int i = 0; i < 26; i++) {
            if(numA[i] != numB[i]) {
                printf("NO\n");
                flag = false;
                break;
            }
        }
        if(flag){
        printf("YES\n");
        }
    }

    return 0;
}

你可能感兴趣的:(ACM,uva,UVa1339)