Prim-POJ-2253-Frogger

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31345 Accepted: 10104
Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
Source

Ulm Local 1997

这道题用prim来做,但不同的是在把第二个岛标记时就可以退出,不用将所有的点都加入树再结束。
同时还有个比较迷的点,如果输出时用%.3lf,会WA,改成%.3f就好了,也是基础知识没学好,scanf中才用%lf的。

//
// main.cpp
// 最短路练习-B-Frogger
//
// Created by 袁子涵 on 15/10/1.
// Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <cmath>

#define pow(x) (x*x)
using namespace std;

typedef struct coor
{
    int x,y;
}Coor;

double cal(Coor a,Coor b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

int N;
bool visit[210];
double dis[210][210],length[210],maxs=8000000;
Coor stone[210];
double out=0;
int main(int argc, const char * argv[]) {
    double Min=maxs;
    int next=1,num=0;
    while (cin >> N && N != 0) {
        out=0.0;
        memset(visit, 0, sizeof(visit));
        memset(dis, 0, sizeof(dis));
        memset(length, 0, sizeof(length));
        memset(stone, 0, sizeof(stone));
        for (int i=1; i<=N; i++) {
            cin >> stone[i].x >> stone[i].y;
        }
        for (int i=1; i<=N; i++) {
            for (int j=i; j<=N; j++) {
                dis[i][j]=cal(stone[i], stone[j]);
                dis[j][i]=dis[i][j];
            }
        }
        visit[1]=1;
        for (int i=1; i<=N; i++) {
            length[i]=dis[1][i];
        }
        while (visit[2]==0) {
            Min=maxs;
            for (int i=1; i<=N; i++) {
                if (length[i]<=Min && visit[i]==0) {
                    Min=length[i];
                    next=i;
                }
            }
            visit[next]=1;
            for (int i=1; i<=N; i++) {
                if (length[i]>dis[next][i]) {
                    length[i]=dis[next][i];
                }
            }
            if (out < Min) {
                out=Min;
            }
        }
        num++;
        printf("Scenario #%d\n",num);
        printf("Frog Distance = %.3f\n\n",out);
        getchar();
    }
    return 0;
}

你可能感兴趣的:(c,Prim)