Red and Black——深搜

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
….#.
…..#
……
……
……
……
……

@…

.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..

.

…@…

.

..#.#..
..#.#..
0 0

Sample Output
45
59
6
13

AC代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<queue>
using namespace std;
int f[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
char a[100][100];
int book[100][100],m,n,s;
int mm,nn;
void dfs(int x,int y);
int main()
{
    int n,m,i,j,yy,ff;
    while(~scanf("%d%d",&n,&m))
    {
        if(m==0&&n==0) return 0;
        getchar();
        memset(book,0,sizeof(book));
        s=1;
        for(i=0;i<m;i++)
        {
            gets(a[i]);
        }
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(a[i][j]=='@')
                {
                    //printf("%d %dpppppppppppppppppppppppppp\n",m,n);
                    yy=i;
                    ff=j;
                }
            }
        }
        mm=m;
        nn=n;
        dfs(yy,ff);
        printf("%d\n",s);
    }
}
void dfs(int x,int y)
{
    //printf("%d------------%d\n",mm,nn);
    int i,fx,fy;
    for(i=0;i<4;i++)
    {
      fx=x+f[i][0];
      fy=y+f[i][1];
       if(fx>=0&&fx<mm&&fy>=0&&fy<nn&&book[fx][fy]==0&&a[fx][fy]=='.')
       {
          //printf("ooooooooooooooooooooooooooo\n");
           s++;
           book[fx][fy]=1;
           dfs(fx,fy);
       }
    }
}

题目传送门:Red and Black(点击可交题)

你可能感兴趣的:(each,Square,Square)