(解题报告)HDU1061---Rightmost Digit

Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

这个题的意思是输出N^N的最后一位数;
我是直接用打表做的,其他方法幂运算的方法正在学习中~~
因为各个数的连乘的最后一位有规律可循,所以找出规律,直接打表;
代码如下:

#include<stdio.h> 
int main()  
{  
 int n;  
 int a[10][4] = {{0},{1},{6,2,4,8},{1,3,9,7},{6,4},{5},{6},{1,7,9,3},{6,8,4,2},{1,9}},d,num;  
 scanf("%d",&num);  
 while(num--)  
 {  
    scanf("%ld",&n);  
    d = n % 10;  
    if(d == 0||d == 1||d == 5||d == 6)  
         printf("%d\n",d);  
    else if(d == 4||d == 9)   
         printf("%d\n",a[d][n % 2]);  
    else if(d == 2||d == 3||d == 7||d == 8)  
         printf("%d\n",a[d][n % 4]);  
 }  
 return 0;  
}  

仅代表个人观点!
(解题报告)HDU1061---Rightmost Digit_第1张图片

你可能感兴趣的:((解题报告)HDU1061---Rightmost Digit)