山东省第二届ACM大学生程序设计竞赛 Identifiers

Identifiers

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

 Identifier is an important concept in the C programming language. Identifiers provide names for several language elements, such as functions, variables, labels, etc.

An identifier is a sequence of characters. A valid identifier can contain only upper and lower case alphabetic characters, underscore and digits, and must begin with an alphabetic character or an underscore. Given a list of chararcter sequences, write a program to check if they are valid identifiers.

输入

 The first line of the input contains one integer, N, indicating the number of strings in the input. N lines follow, each of which contains at least one and no more than 100 characters. (only upper and lower case alphabetic characters, digits, underscore (" "), hyphen ("-"), period ("."), comma (","), colon (":"), semicolon (";"), exclamation mark ("!"), question mark ("?"), single and double quotation marks, parentheses, white space and square brackets may appear in the character sequences.)

输出

For each of the N lines, output "Yes" (without quote marks) if the character sequence contained in that line make a valid identifier; output "No" (without quote marks) otherwise.

示例输入

7
ValidIdentifier
valid_identifier
valid_identifier
0 invalid identifier
1234567
invalid identifier
adefhklmruvwxyz12356790 -.,:;!?'"()[]ABCDGIJLMQRSTVWXYZ

示例输出

Yes
Yes
Yes
No
No
No
No

提示

 

来源

山东省第二届ACM大学生程序设计竞赛

示例程序

判断是否有特殊符号

ACcode:

#include <map>    
#include <queue>    
#include <cmath>    
#include <cstdio>    
#include <cstring>    
#include <stdlib.h>    
#include <iostream>    
#include <algorithm>    
#define maxn 1000    
using namespace std;    
char s[maxn];    
int loop;    
void doit(){    
    gets(s);    
    int len=strlen(s);    
     if((s[0]>='A'&&s[0]<='Z') || (s[0]>='a'&&s[0]<='z')|| s[0]=='_');else{    
        printf("No\n");return;    
     }    
    for(int i=1;i<len;++i)    
        if((s[i]>='A'&&s[i]<='Z') || (s[i]>='a'&&s[i]<='z')||(s[i]<='9'&&s[i]>='0')|| s[i]=='_');    
        else{    
            printf("No\n");    
            return ;    
        }    
    printf("Yes\n");    
}    
int main(){    
    scanf("%d",&loop);getchar();   
    while(loop--)doit();    
    return 0;    
}     
  
  
  
/************************************** 
    Problem id  : SDUT OJ 2163  
    User name   : acmer  
    Result      : Accepted  
    Take Memory : 488K  
    Take Time   : 0MS  
    Submit Time : 2016-04-04 20:28:49   
**************************************/  


你可能感兴趣的:(山东省第二届ACM大学生程序设计竞赛 Identifiers)