有序链表的归并

数据结构实验之链表四:有序链表的归并

Time Limit: 1000MS Memory limit: 65536K

题目描述

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

输入

第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

输出

输出合并后的单链表所包含的M+N个有序的整数。

示例输入

6 5
1 23 26 45 66 99
14 21 28 50 100

示例输出

1 14 21 23 26 28 45 50 66 99 100

提示

不得使用数组!

#include<stdio.h>
#include<stdlib.h>
struct nobe
{
    int data;
    struct nobe *next;
}*p,*head1,*head2,*tail,*q1,*q2;
int main()
{
    int n,m;
    head1=(struct nobe *)malloc(sizeof(struct nobe));
    head1->next =NULL;
    tail=head1;
    scanf("%d%d",&n,&m);
    while(n--)
    {
        p=(struct nobe* )malloc(sizeof(struct nobe));
        p->next=NULL;
        scanf("%d",&p->data);
        tail->next=p;
        tail=p;
    }
    head2=(struct nobe*)malloc(sizeof(struct nobe));
    head2->next=NULL;
    tail=head2;
    while(m--)
    {
        p=(struct nobe*)malloc(sizeof(struct nobe));
        p->next=NULL;
        scanf("%d",&p->data);
        tail->next=p;
        tail=p;
    }
    q1=head1->next;
    q2=head2->next;
    tail=head1;
    while(q1&&q2)
    {
        if(q1->data<q2->data)
        {
            tail->next=q1;
            tail=q1;
            q1=q1->next;
            tail->next=NULL;
        }
        else
        {
            tail->next=q2;
            tail=q2;
            q2=q2->next;
            tail->next=NULL;
        }
    }
    if(q1)
    {
        tail->next=q1;
    }
    else
    tail->next=q2;

    p=head1->next;
    int kkk=1;
    while(p)
    {
        if(kkk==1)
        kkk=0;
        else
        printf(" ");
        printf("%d",p->data);
        p=p->next;
    }
    printf("\n");
    return 0;
}


你可能感兴趣的:(有序链表的归并)