PAT-PAT (Advanced Level) Practise String Subtraction (20)【一星级】

题目链接:http://www.patest.cn/contests/pat-a-practise/1050


题面:

1050. String Subtraction (20)

时间限制
10 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
题目大意:

  b中出现字符,a中不再出现,标记一下即可。


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cstring>
#include <string>
#include <map> 
using namespace std;
#define LL long long 
bool s[300];
int main()
{	
    string a,b,ans="";
	getline(cin,a);
	getline(cin,b);
	int len=b.length();
	memset(s,-1,sizeof(s));
	for(int i=0;i<len;i++)
	  s[b[i]]=0;
    len=a.length();
    for(int i=0;i<len;i++)
    {
    	if(s[a[i]])
    	  ans+=a[i];
    }
    cout<<ans<<endl;
	return 0;
} 


你可能感兴趣的:(入门,pat)