3017
Problem Q
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 62 Accepted Submission(s) : 22
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …<br>The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?<br><center><img src=../../../data/images/C154-1003-1.jpg> </center><br>
Input
The first line contain a integer T , the number of cases.<br>Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2<sup>31</sup>).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
题意:
不同的骨头有不同的价值,在袋子的体积确定的情况下求收藏家所能得到的最大价值;
思路:
用f[i][j]表示前i件物品用最大负重j的袋子所能装的最大权值
f[i][v]=max{f[i-1][v],f[i-1][v-c[i]]+w[i]};
AC代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int w[1005];
int v[1005];
int dp[1005];
int main()
{
int t,n,m;
scanf("%d",&t);
while(t--)
{
memset(w,0,sizeof(w));
memset(v,0,sizeof(v));
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
scanf("%d",&v[i]);
for(int i=1;i<=n;i++)
scanf("%d",&w[i]);
for(int i=1;i<=n;i++)
{
for(int j=m;j>=0;j--)
{
if(j>=w[i])//注意=号
dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
}
}
printf("%d\n",dp[m]);
}
return 0;
}