POJ 2456 (二分)

Aggressive cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9377   Accepted: 4663

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Source

USACO 2005 February Gold


题意是给定n个农舍的位置和m头牛,每头牛放到不同的农舍使得最近的两头牛距离尽量短。

二分枚举最短的距离然后每次贪心遍历一遍判断是否能够取到。

#include <iostream>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cstdio>
using namespace std;
typedef unsigned long long ull;
#define maxn 111111

long long a[maxn];
int n, m;

bool ok (long long d) {
	long long pre = a[1];
	int ans = 1;
	for (int i = 2; i <= n; i++) {
		if (a[i]-pre >= d) {
			pre = a[i];
			ans++;
		}
	}
	return ans >= m;
}

int main () {
	while (scanf ("%d%d", &n, &m) == 2) {
		for (int i = 1; i <= n; i++) {
			scanf ("%lld", &a[i]);
		}
		sort (a+1, a+1+n);
		long long l = 0, r = a[n]-a[1];
		while (r-l > 1) {
			long long mid = (l+r)>>1;
			if (ok (mid))
				l = mid;
			else
				r = mid;
		} 
		if (ok (l))
			printf ("%lld\n", l);
		else 
			printf ("%lld\n", r);
	}
	return 0;
}






你可能感兴趣的:(POJ 2456 (二分))