The Lucky Week

The Lucky Week Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward, the headmaster of the Marjar University, is very busy every day and always forgets the date.

There was one day Edward suddenly found that if Monday was the 1st, 11th or 21st day of that month, he could remember the date clearly in that week. Therefore, he called such week "The Lucky Week".

But now Edward only remembers the date of his first Lucky Week because of the age-related memory loss, and he wants to know the date of the N-th Lucky Week. Can you help him?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

The only line contains four integers Y, M, D and N (1 ≤ N ≤ 109) indicating the date (Y: year, M: month, D: day) of the Monday of the first Lucky Week and the Edward's query N.

The Monday of the first Lucky Week is between 1st Jan, 1753 and 31st Dec, 9999 (inclusive).

Output

For each case, print the date of the Monday of the N-th Lucky Week.

Sample Input

2
2016 4 11 2
2016 1 11 10

Sample Output

2016 7 11
2017 9 11
 
 
题意:当日期为 1,11,21 并且当天为周一时  认为这一周为Lucky Week 
      给出起始lucky week 问之后第N个lucky week的 日期

题解:1.暴力找循环节 每400年中有2058个lucky week
     2.然后就是暴力
#include<stdio.h>
int  d1[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};//平年的每个月的天数
int  d2[13]= {0,31,29,31,30,31,30,31,31,30,31,30,31};//闰年的每个月的天数
int y(int g)//判断是闰年还是平年
{
    if(g%400==0||g%4==0&&g%100!=0)
    {
        return 1;
    }
    else
    {
        return 0;
    }
}
int main()
{
    int t,a,b,c,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d %d %d",&a,&b,&c,&n);
        int we=n/2058;
        we=we*400;
        int f=n%2058;
        while(f)//暴力寻找
        {
            if(c==1||c==11||c==21)
            {
                f--;
            }
            if(f==0)
            {
                break;
            }
            if(y(a))
            {
                c=c+7;
                if(c>d2[b])
                {
                    c=c-d2[b];
                    b=b+1;
                }
                if(b>12)
                {
                    a=a+1;
                    b=1;
                }
            }
            else if(!y(a))
            {
                c=c+7;
                if(c>d1[b])
                {
                    c=c-d1[b];
                      b=b+1;
                }
                if(b>12)
                {
                    a=a+1;
                    b=1;
                }
            }
        }
        printf("%d %d %d\n",a+we,b,c);
    }
}

你可能感兴趣的:(The Lucky Week)