ztr loves math

ztr loves math

Accepts: 303
Submissions: 1975
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
Problem Description

ztr loves research Math.One day,He thought about the "Lower Edition" of triangle equation set.Such as n=x2−y2n=x^{2}-y^{2}n=x2y2.

He wanted to know that ,for a given number n,is there a positive integer solutions?

Input

There are T test cases. The first line of input contains an positive integer T(T<=106)T(T<=10^{6})T(T<=106) indicating the number of test cases.

For each test case:each line contains a positive integer ,n<=1018n <=10^{18}n<=1018.

Output

If there be a positive integer solutions,print TrueTrueTrue,else print FalseFalseFalse

Sample Input
Copy
4
6
25
81
105
Sample Output
Copy
False
True
True
True


     
     
     
     
Hint
For the fourth case, 105=132−82105 = 13^{2}-8^{2}105=13282
#include<stdio.h>
#include<math.h>
int main()
{
    int t,i,j;
    long long int n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        int p=1;
         if(n==1||n==2||n==4)
         {
             p=0;
         }
         if(n>6)
         {
             if(n%4==0)
             {
                 p=0;
             }
         }
         if(p)
         {
             printf("True\n");
         }
         else
         {
             printf("False\n");
         }
    }
}

你可能感兴趣的:(ztr loves math)