山东省第一届ACM大学生程序设计竞赛 Emergency floyd变形

Emergency

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Kudo’s real name is not Kudo. Her name is Kudryavka Anatolyevna Strugatskia, and Kudo is only her nickname.
Now, she is facing an emergency in her hometown:
Her mother is developing a new kind of spacecraft. This plan costs enormous energy but finally failed. What’s more, because of the failed project, the government doesn’t have enough resource take measure to the rising sea levels caused by global warming, lead to an island flooded by the sea.
Dissatisfied with her mother’s spacecraft and the government, civil war has broken out. The foe wants to arrest the spacecraft project’s participants and the “Chief criminal” – Kudo’s mother – Doctor T’s family.
At the beginning of the war, all the cities are occupied by the foe. But as time goes by, the cities recaptured one by one.
To prevent from the foe’s arrest and boost morale, Kudo and some other people have to distract from a city to another. Although they can use some other means to transport, the most convenient way is using the inter-city roads. Assuming the city as a node and an inter-city road as an edge, you can treat the map as a weighted directed multigraph. An inter-city road is available if both its endpoint is recaptured.
Here comes the problem
Given the traffic map, and the recaptured situation, can you tell Kudo what’s the shortest path from one city to another only passing the recaptured cities?

输入


The input consists of several test cases.
The first line of input in each test case contains three integers N (0<N300), M (0<M100000) and Q (0<Q100000), which represents the number of cities, the numbers of inter-city roads and the number of operations.
Each of the next M lines contains three integer x, y and z, represents there is an inter-city road starts from x, end up withy and the length is z. You can assume that 0<z10000.
Each of the next Q lines contains the operations with the following format: 
a) 0 x – means city x has just been recaptured. 
b) 1 x y – means asking the shortest path from x to y only passing the recaptured cities.
The last case is followed by a line containing three zeros.

输出

For each case, print the case number (1, 2 …) first.
For each operation 0, if city x is already recaptured (that is,the same 0 x operation appears again), print “City x is already recaptured.”
For each operation 1, if city x or y is not recaptured yet, print “City x or y is not available.” otherwise if Kudo can go from city x to city y only passing the recaptured cities, print the shortest path’s length; otherwise print “No such path.”
Your output format should imitate the sample output. Print a blank line after each test case.

示例输入

3 3 6
0 1 1
1 2 1
0 2 3
1 0 2
0 0
0 2
1 0 2
1 2 0
0 2

0 0 0

示例输出

Case 1:
City 0 or 2 is not available.
3
No such path.
City 2 is already recaptured.

提示

 

来源

 2010年山东省第一届ACM大学生程序设计竞赛

题目描述,有n座城市,m条路径,单向路,0代表占领某一座城市,1代表求从x点到y点的最小路径,此时的路径必须是通过已经占领的城市,4种输出,没有占领那个城市,已经占领那个城市求出最短路径,求不出最短路径,重复占领。
一开始我想用djk各种t最后搜索一发发现正确的姿势的改版的floyd 

变形的弗洛伊德算法,三重for循环,变化为3个两重for循环
初始时,所有的城市都没有被占领,每加入一座城市被占领,就更新所有由那个点到所有点的最短路径,和所有点到那个点的最短路径,再更新通过那个点,改变的由任意两个点的最短路径,得到最短路
AcCODE:
#include <map>  
#include <queue>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <stdlib.h>  
#include <iostream>  
#include <algorithm>  
#define maxn 100100  
#define inf 0x3f3f3f  
using namespace std;  
bool isused[maxn];  
int cost[500][500];  
void Floyd(int n,int k){  
    int i,j;  
        for(i=0;i<n;i++)  
            for(j=0;j<n;j++)  
                if(cost[i][j]>cost[i][k]+cost[k][j])  
                    cost[i][j]=cost[i][k]+cost[k][j];  
}  
void add(){  
    int u,v,w;  
    scanf("%d%d%d",&u,&v,&w);  
    if(w<cost[u][v])cost[u][v]=w;  
}  
int main(){  
    int n,m,q,nn,loop=1;  
    while(~scanf("%d%d%d",&n,&m,&q)&&n+m+q){  
        for(int i=0;i<n;++i)for(int j=0;j<n;++j){  
                cost[i][j]=inf;  
                if(i==j)cost[i][j]=0;  
        }  
        while(m--)add();  
        memset(isused,false,sizeof(isused));  
        printf("Case %d:\n",loop++);  
        while(q--){  
            int u,v;  
            scanf("%d",&u);  
            if(u==0){  
                scanf("%d",&v);  
                if(isused[v])  
                    printf("City %d is already recaptured.\n",v);  
                else {  
                    isused[v]=true;  
                    Floyd(n,v);  
                }  
            }  
            else {  
                scanf("%d%d",&u,&v);  
                if(isused[u]&&isused[v]){  
                    if(cost[u][v]==inf)  
                        printf("No such path.\n");  
                    else  
                        printf("%d\n",cost[u][v]);  
                }  
                else  
                    printf("City %d or %d is not available.\n",u,v);  
            }  
        }  
        printf("\n");  
    }  
    return 0;  
}  
/* 
3 3 6 
0 1 1 
1 2 1 
0 2 3 
1 0 2 
0 0 
0 2 
1 0 2 
1 2 0 
0 2 
 
0 0 0 
*/  
   
  
  
  
/************************************** 
    Problem id  : SDUT OJ 2155  
    User name   : acmer  
    Result      : Accepted  
    Take Memory : 1188K  
    Take Time   : 140MS  
    Submit Time : 2016-04-01 21:03:14   
**************************************/  



你可能感兴趣的:(ACM)