UVA 10004 Bicoloring

[PDF Link]


Description

In 1976 the ``Four Color Map Theorem" was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the same color as a neighbor region.

Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume:

   1.no node will have an edge to itself.
   2.the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must assume that b is connected to a.
   3.the graph will be strongly connected. That is, there will be at least one path from any node to any other node. 

Input

The input consists of several test cases. Each test case starts with a line containing the number n ( 1 < n < 200) of different nodes. The second line contains the number of edges l. After this, l lines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph will be labeled using a number a ( 0 < a < n).

An input with n = 0 will mark the end of the input and is not to be processed. 

Output

You have to decide whether the input graph can be bicolored or not, and print it as shown below. 

Sample Input

3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0

Sample Output

NOT BICOLORABLE.
BICOLORABLE.

双色问题:
给出一个联通图,要求在个点上染上两种颜色,相邻的点颜色不能相同,看能不能染色成功。

条件:

1、不存在环

2、图是连通图

3、无向图
思路:
以一个点为起点,按宽度优先的方法遍历整个图,如果没有染色,就给它都染上颜色,如果已经染色,判断与周围的点颜色是不是相同。   <(^-^)>
      代码    (๑•̀ㅂ•́)و✧↓↓↓↓↓↓↓↓↓


 #include<iostream>
 #include <cstdio>
 #include <string.h>
 #include <queue>
 #define N 202
using namespace std;
const char *z = "BICOLORABLE.", *zz = "NOT BICOLORABLE." ;
int n, m, a[N][N], vis[N], c[N];
bool bfs()
{
    vis[0] = 1;
    c[0] = 1;
    int nx, ny, now;
    queue<int> q;
    q.push(0);
    while (!q.empty())
    {
        now = q.front();
        q.pop();
        for (int i = 0; i < n; i++)
        {
            if (a[now][i])
            {
                if(!vis[i])
                {
                    vis[i] = 1;
                    c[i] = ((c[now]==1) ? 2:1);
                    q.push(i);
                }
                else if (c[i] == c[now])
                {
                    return false;
                }   
            }
        }
    }
    return true;
}
int main()
{
 #ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
 #endif
    int i, j, x, y;
    while(scanf("%d", &n), n)
    {
        scanf("%d", &m);
        memset(vis, 0, sizeof(vis));
        memset(c, 0, sizeof(c));
        memset(a, 0, sizeof(a));
        for (i = 0; i < m; i++)
        {
            scanf("%d%d", &x, &y);
            a[x][y] = a[y][x] = 1;
        }
        if (bfs())
        {
            puts(z);
        }
        else
        {
            puts(zz);
        }
    }
    return 0;
} 

你可能感兴趣的:(uva,bfs)