HDU 5676 ztr loves lucky numbers

Problem Description
ztr loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn't contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not.

Lucky number is super lucky if it's decimal representation contains equal amount of digits 4 and 7. For example, numbers 47, 7744, 474477 are super lucky and 4, 744, 467 are not.

One day ztr came across a positive integer n. Help him to find the least super lucky number which is not less than n.
 

Input
There are T (1n105)  cases

For each cases:

The only line contains a positive integer  n(1n1018) . This number doesn't have leading zeroes.
 

Output
For each cases
Output the answer
 

Sample Input
   
   
   
   
2 4500 47
 

Sample Output
   
   
   
   
4747 47

先预处理出全部答案,然后询问的时候二分即可,需要注意的是最大的那个数会爆longlong,需要特判一下。

#include<cstdio>
#include<algorithm>
using namespace std;
typedef unsigned long long LL;
const int maxn = 1e5 + 10;
int T, m;
LL n, a[maxn];

void init(LL y, int l, int r)
{
	if (l + r > 18) return;
	if (l == r) a[m++] = y;
	init(y * 10 + 4, l + 1, r);
	init(y * 10 + 7, l, r + 1);
}

int main()
{
	init(0, 0, 0);
	sort(a, a + m);
	scanf("%d", &T);
	while (T--)
	{
		scanf("%llu", &n);
		int k = lower_bound(a + 1, a + m, n) - a;
		if (k < m) printf("%llu\n", a[k]);
		else printf("44444444447777777777\n");
	}
	return 0;
}


你可能感兴趣的:(HDU)