HDU-3625-Examining the Rooms

Problem Description

A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.

Input

The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)

Output

Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.

Sample Input

3
3 1
3 2
4 2

Sample Output

0.3333
0.6667
0.6250

Hint

Sample Explanation
When N = 3, there are 6 possible distributions of keys:
Room 1  Room 2  Room 3  Destroy Times
 #1 Key 1   Key 2   Key 3   Impossible
 #2 Key 1   Key 3   Key 2   Impossible
 #3 Key 2   Key 1   Key 3   Two
 #4 Key 3   Key 2   Key 1   Two
 #5 Key 2   Key 3   Key 1   One
 #6 Key 3   Key 1   Key 2   One
In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1. 
In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room 

第一类斯特林数
题目还有个特殊要求,不能破1号的门。
也就是说1号不能独立成环,否则就失败。
第一类斯特林数S(P,K)=(P-1)*S(P-1,K)+S(P-1,K-1)表示的正是N个元素形个K个非空循环排列的方法数。枚举形成的环,但是要除掉1号独立成环的可能。
S(N,M)-S(N-1,M-1),N个元素形成 M个环,减去除了1之外的N-1个元素形成M-1个环,也就是1独立成环。
代码:

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <set>
#define N 1000005
#define ll long long
using namespace std;
int n, k;
long long stir1[22][22], fac[22];
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int i, j, T;
    long long sum;
    double ans;
    fac[1] = 1;
    memset(stir1, 0, sizeof(stir1));
    for (i = 2; i <= 20; i++)
        fac[i] = fac[i-1]*i;
    for (i = 1; i <= 20; i ++)
    {
        stir1[i][0] = 0;
        stir1[i][i] = 1;
        for (j = 1; j < i; j++)
            stir1[i][j] = (i-1)*stir1[i-1][j] + stir1[i-1][j-1];
    }
    cin >> T;
    while(T--)
    {
        cin >> n >> k;
        if (n == 1 || !k)
        {
            cout << "0.000\n";
            continue;
        }
        sum = 0;
        for (i = 1; i <= k; i++)
            sum += stir1[n][i] - stir1[n-1][i-1];
        ans = sum*1.0/fac[n];
        cout.setf(ios::fixed);
        cout << setprecision(4) << ans << endl;
    }
    return 0;
}

你可能感兴趣的:(HDU-3625-Examining the Rooms)