hduoj1087!【DP】

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the maximum according to rules, and one line one case.
 
Sample Input
   
   
   
   
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 
Sample Output
   
   
   
   
4 10 3
 
Author
lcy

 

题目意思就是给出一串数字, 求出最大序列和, 所得序列要求前一个必须小于后一个,序列个数可以是任意的。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int ma(int x,int y)
{
	return x>y?x:y;
}
int cmp(const void *a, const void *b)
{
	return *(int *)b - *(int *)a;
}
int main()
{
	int a[1010], i, j, max,  n, b[1010];
	while(scanf("%d", &n) != EOF && n)
	{
		memset(a, 0, sizeof(a));
		memset(b, 0, sizeof(b));
		for(i = 1; i <= n; i++)
		scanf("%d", &a[i]);
		for(j = 1; j <= n; j++)
		{
			for(i = j-1; i >= 0; i--)
			if(a[j] > a[i])
			b[j] = ma(b[j],b[i]+a[j]);
		}
		qsort(b, n+1, sizeof(b[0]), cmp);
		printf("%d\n", b[0]);
	}
	return 0;
}

 

思路是从正面求,1到i的最大序列和, 每增加一个数,判断当前i的序列和是否需要改变。

你可能感兴趣的:(c)