poj-1905-Expanding Rods

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000


一根两端固定在两面墙上的杆 受热弯曲后变弯曲

求前后两个状态的杆的中点位置的距离



这是一道数学题。主要是推出两个公式就好了。

1)       角度→弧度公式  θr = 1/2*s

(2)       三角函数公式  sinθ= 1/2*L/r

(3)       勾股定理  r^2 – ( r – h)^2 = (1/2*L)^2

知道这三个公式可以推出

poj-1905-Expanding Rods_第1张图片

然后就可以二分去找了。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;

const double esp=1e-5;

int main()
{
    double l,t,c;
    double r,s;
    while(scanf("%lf%lf%lf",&l,&t,&c)!=EOF)
    {
        if(l==-1&&t==-1&&c==-1) break;
        double low = 0.0;
        double high = l;
        double mid;
        s=(1+t*c)*l;
        while(high-low>esp)
        {
            mid=(high+low)/2;
            r=(4*mid*mid+l*l)/(8*mid);
            if( 2*r*asin(l/(2*r))< s)
                low=mid;
            else
                high=mid;
        }
        printf("%.3f\n",mid);
    }
    return 0;
}


你可能感兴趣的:(数学,二分)