Pat(Advanced Level)Practice--1059(Prime Factors)

Pat1059代码

题目描述:

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291


注意n=1的情况,剩下的就是素数的筛选。
AC代码:
#include<cstdio>

using namespace std;

int IsPrime(long long n)
{
	if(n==2)
		return 1;
	if(n<2||n%2==0)
		return 0;
	for(long long i=3;i*i<=n;i+=2)
		if(n%i==0)
			return 0;
	return 1;
}

int main(int argc,char *argv[])
{
	long long n;
	long long i;
	scanf("%lld",&n);
	printf("%lld=",n);
	if(n==1)
		printf("%lld\n",n);
	else
	{
		long long i,temp;
		temp=n;
		for(i=2;i<=temp;i++)
		{
			int k=0;
			if(IsPrime(i))
			{
				while(n%i==0)
				{
					k++;
					n/=i;
				}
			}
			if(k>1)
				printf("%lld^%d",i,k);
			else if(k==1)
				printf("%lld",i);
			if(n==1)
				break;
			else if(k>=1)
				printf("*");
		}
		printf("\n");
	}
	return 0;
}



你可能感兴趣的:(C++,pat,基础题,advance,素数筛选)