HDU 2602 Bone Collector (简单的0-1背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24860    Accepted Submission(s): 10062


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDU 2602 Bone Collector (简单的0-1背包)_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14
 

Author
Teddy
 

Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
 

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <climits>

const int MAX = 1011;

int value[MAX],cost[MAX],pack[MAX];

void init(){
	int i;

	for(i=0;i<MAX;++i)pack[i] = 0;
}

void max(int &a,int b){
	if(a<b) a = b;
}

void zeroOnePack(int V,int n){
	int i,v;

	for(i=0;i<n;++i){
		for(v=V;v>=cost[i];--v){
			max(pack[v],pack[v-cost[i]]+value[i]);
		}
	}
}

int main(){
	int t,n,all,i;
	//freopen("in.txt","r",stdin);
	scanf("%d",&t);
	while(t--){
		init();
		scanf("%d %d",&n,&all);
		for(i=0;i<n;++i){
			scanf("%d",&value[i]);
		}
		for(i=0;i<n;++i){
			scanf("%d",&cost[i]);
		}
		zeroOnePack(all,n);
		printf("%d\n",pack[all]);
	}
	return 0;
}




你可能感兴趣的:(动态规划,HDU,背包,0-1背包)