hdu 2602 Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 47079    Accepted Submission(s): 19624


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
hdu 2602 Bone Collector_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14
 

Author
Teddy
 

Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest


这是一道标准的01背包模板题;
套一下模板即可;

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int N,V;
int F[1001];
int val[1001];
int vol[1001];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&N,&V);
        memset(F,0,sizeof(F));
        for(int i=1;i<=N;++i)
        {
            scanf("%d",&val[i]);
        }
        for(int i=1;i<=N;++i)
        {
            scanf("%d",&vol[i]);
        }
        for(int i=1;i<=N;++i)
        {
            for(int j=V;j>=vol[i];--j)
            {
                F[j]=max(F[j],F[j-vol[i]]+val[i]);
            }
        }
        printf("%d\n",F[V]);
    }
    return 0;
}


你可能感兴趣的:(HDU,背包)