快速幂-HDOJ-5363-Key Set

Key Set

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1175 Accepted Submission(s): 669

Problem Description
soda has a set S with n integers {1,2,…,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.

Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤109), the number of integers in the set.

Output
For each test case, output the number of key sets modulo 1000000007.

Sample Input
4
1
2
3
4

Sample Output
0
1
3
7

直接快速幂。

//
// main.cpp
// 150806-1011
//
// Created by 袁子涵 on 15/8/6.
// Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>

using namespace std;

unsigned long long int T;
unsigned long long int n;
unsigned long long int a,b,c;

long long result(long long a,long long b,long long m)
{
    long long d,t;

    d=1;
    t=a;
    while (b>0)
    {
        if (b%2==1)
            d=(d*t)%m;
        b/=2;
        t=(t*t)%m;
    }
    return d;
}

int main(int argc, const char * argv[]) {
    cin >> T;
    while (T--) {
        scanf("%llu",&n);
        if (n==1) {
            printf("0\n");
            continue;
        }
        b=result(2, n-1, 1000000007);
        cout << (b-1) << endl;
    }
    return 0;
}

你可能感兴趣的:(c)