poj——2406Power Strings(kmp专练)

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 41658 Accepted: 17323
Description


Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input


Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output


For each s you should print the largest n such that s = a^n for some string a.
Sample Input


abcd
aaaa
ababab
.
Sample Output


1
4
3
Hint


This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source


Waterloo local 2002.07.01


解题思路:找出循环节  用总长度除一下得出循环次数 如果除不尽说明循环一次


#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int nexta[4000100];
void getnext(string n)
{
	int i=0,j=-1;
	nexta[0]=-1;
	while(i<n.size())
	{
		if(j==-1||n[i]==n[j])
		{
			++i;
			++j;
			nexta[i]=j;
		}
		else j=nexta[j];
	}
}
int main()
{
	string n;
	long long a,k,i;
	ios::sync_with_stdio(false);
	while(cin>>n&&n!=".")
	{
		getnext(n);
		i=n.size();
		k=i-nexta[i];//循环节 
		if(i%k==0)
		{
			cout<<i/k<<endl;
		}
		else cout<<"1"<<endl;
	}
	return 0;
} 

你可能感兴趣的:(C++,String,KMP,poj)