Moving Tables

Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5137 Accepted Submission(s): 1435
 
Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

Moving Tables_第1张图片

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

Moving Tables_第2张图片

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 
Sample Input
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50 
 
Sample Output
10 20 30
 
 
Source
Asia 2001, Taejon (South Korea)
 


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct t
{
    int table1;
    int table2;
};
typedef struct t Table;

int com(const void *a, const void *b)
{
    return *(int *)b - *(int *)a;
}
int main()
{
    int T;//测试实例数
    int N;//移动桌子的张数
    int i, j;//循环变量
    Table table[210];
    int corridor[210];
    int  t;
    scanf("%d", &T);
    do
    {
        memset(corridor, 0, sizeof(corridor));
        scanf("%d", &N);
        for(i=0;i<N;i++)
        {
            scanf("%d%d", &table[i].table1, &table[i].table2);
            if(table[i].table1>table[i].table2)
                {
                    t=table[i].table1;
                    table[i].table1=table[i].table2;
                    table[i].table2=t;
                }


            if(table[i].table1%2==0)
            {
                --table[i].table1;
            }
            if(table[i].table2%2==0)
            {
                --table[i].table2;
            }//映射到奇数排
        }

         for(i=0;i<N;i++)
         {
             for(j=(table[i].table1+1)/2-1;j<=(table[i].table2+1)/2-1;++j)
                ++corridor[j];
         }

        qsort(corridor, 210, sizeof(int), com);

        printf("%d\n", corridor[0]*10);

    }while(--T);

    return 0;
}


做了一上午,终于AC掉了,提交了八次。。。明明自己例子外加自己找的数据全都,可提交就是wrong answer ,最终想不明白百度了一下答案,阅读答案时发现被坑了一上午(主要是做题少的原因可能),直至缺少的代码如上面的红色部分,我没有想过房间号先大后小的情况,一直以为是解题方法的错误。。。
     这题思路是找重叠的最大部分我们可以把1,2之间的区域看成corridor[0],3,4之间的看成corridor[1],以此类推。找出重叠次数最多的区域,该区域的重叠次数乘以10就是答案。

你可能感兴趣的:(ACM,水题)