Hduoj1009!【水题】

/*FatMouse' Trade
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42785    Accepted Submission(s): 14273


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to 
trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is 
a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. 
Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's.
 All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans 
that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 
Sample Output
13.333
31.500
 
Author
CHEN, Yue
 
Source
ZJCPC2004 
*/
#include<stdio.h>
#include<stdlib.h>
struct rate
{
    double a;
    double b;
    double rt;
}rat[1010];
int cmp(const void *a, const void *b)
{
    return (*(rate *)b).rt > (*(rate *)a).rt ? 1:-1 ;
}
int main()
{
    int m, n, i;
    double sum, x;
    while(scanf("%d%d", &m, &n) != EOF &&( m != -1 || n != -1))
    {
        x = (double)m;
        for( i = 0; i  < n; i++)
        {
            scanf("%lf%lf", &rat[i].a, &rat[i].b);
            if( rat[i].b != 0)
            rat[i].rt = rat[i].a / rat[i].b;
            else
            rat[i].rt = 0;
        }
        qsort(rat, n, sizeof(rat[0]), cmp);
        sum = 0;
        for(i = 0 ; i < n; i++)
        {
            if( x >= rat[i].b )
            {
                sum += rat[i].a;
                x -= rat[i].b;
            }
            else
            {
                if(x > 0)
                {
                    sum += (x / rat[i].b) * rat[i].a;
                    x = 0;
                }
            }
        }
        printf("%.3lf\n", sum);
    }
    return 0;
}

题意:给出n对数,每一对数表示老鼠可以获得j[i]的鼠粮并付出f[i]的猫粮和猫做交易,求老鼠以m的猫粮能获得的最多的数量为多少。

思路:将每件以比例来算可以获取最优的答案,根据比例进行排序排序后按量获取即可。值得注意的是当F[i] = 0时,也要全部计入总和;

你可能感兴趣的:(Hduoj1009!【水题】)