Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 90023 Accepted Submission(s): 34158
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
Author
WU, Jiazhi
Source
ZJCPC2004
//此题题意:让你求出给出一组数据中颜色气球类最多的一种,并输出。
代码如下:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int main()
{ int n;
char s[1001][16];
int num[1001];
while(scanf("%d",&n)!=EOF,n)
{
memset(num,0,sizeof(num));//数组清零;
for(int i=0;i<n;i++)
{
scanf("%s",s[i]);
for(int j=0;j<i-1;j++)
{
if(strcmp(s[i],s[j])==0)//比较
num[j]++;
}
}
int maxi=0,t=0;
for(int i=0;i<n;i++)//判断
{
if(num[i]>maxi)
{maxi=num[i];
t=i;
}
}
cout<<s[t]<<endl;
}
return 0;
}