不无聊的序列(Non-boring sequences,Bzoj4059,CERC2012)

AC通道:http://www.lydsy.com/JudgeOnline/problem.php?id=4059

不无聊的序列

Description

我们害怕把这道题题面搞得太无聊了,所以我们决定让这题超短。
一个序列被称为是不无聊的,仅当它的每个连续子序列存在一个独一无二的数字,即每个子序列里至少存在一个数字只出现一次。
给定一个整数序列,请你判断它是不是不无聊的。

Input

第一行一个正整数T,表示有T组数据。
每组数据第一行一个正整数n,表示序列的长度, 1<=n<=200000
接下来一行n个不超过 109 的非负整数,表示这个序列。

Output

对于每组数据输出一行,输出” nonboring ”表示这个序列不无聊,输出” boring ”表示这个序列无聊。

Sample Input

4
5
1 2 3 4 5
5
1 1 1 1 1
5
1 2 3 2 1
5
1 1 2 1 1

Sample Output

non-boring
boring
non-boring
boring

Solution

算法很显然:
一、在区间 [l,r] 找到一个只出现一次的元素 P (如果不存在,那么序列无聊)
二、递归处理区间 [l,p1] 和区间 [p+1,r]

关键在于如何找到一个只出现一次的元素。

首先,我们得知道如何判断一个元素是不是只出现一次。
我们可以用 STL 中的 map 记录与当前元素值相同的上一个元素(下一个元素)的位置,然后滚动更新即可。
因为 map 的所有操作都是 O(logn) 的,所以预处理的时间复杂度为 O(nlogn)

所以,我们就可以用 O(1) 的时间判断出一个元素是不是只出现一次了。

若从左到右扫描整个序列,那么最坏情况,这个元素在序列的最右边,则
T(n)=T(n1)+O(n)T(n2)=O(n2)

根据二分法一般是尽量分成两个数量尽量接近的数列,我们可以考虑从两边往中间找。
此时,最坏情况为这个元素在序列的正中间,则
T(n)=2T(n/2)+O(n) ,解得 T(n)=O(nlogn)

所以算法的总时间复杂度为 O(nlogn)

Code

#include <iostream>
#include <cstdio>
#include <map>

using namespace std;

int s[200010];
int last[200010];
int nxt[200010];
map<int,int>be;
map<int,int>wi;

bool solve(int l,int r){
    if(l>=r)return true;
    int x=l,y=r; 
    while(x<=y){
        if(last[x]<l&&nxt[x]>r)
            return solve(l,x-1)&&solve(x+1,r);
        else if(last[y]<l&&nxt[y]>r)
                return solve(l,y-1)&&solve(y+1,r);
        x++;
        y--;
    }
    return false;
}

int main(){
    int t;
    scanf("%d",&t);
    for(int ttt=1;ttt<=t;ttt++){
        int n;
        scanf("%d",&n);
        be.clear();
        wi.clear();
        for(int i=1;i<=n;i++){
            scanf("%d",&s[i]);
            if(!be.count(s[i]))last[i]=-1;
            else last[i]=be[s[i]];
            be[s[i]]=i;
        }
        for(int i=n;i>=1;i--){
            if(!wi.count(s[i]))nxt[i]=n+1;
            else nxt[i]=wi[s[i]];
            wi[s[i]]=i;
        }
        if(solve(1,n))printf("non-boring");
        else printf("boring");
        if(ttt!=t)printf("\n");
    }   
    return 0;
}

你可能感兴趣的:(分治)