Zoj 3947 Very Happy Great BG【水】

Very Happy Great BG Time Limit: 2 Seconds       Memory Limit: 65536 KB

The summer training of ZJU ICPC in July is about to end. To celebrate this great and happy day, the coach of ZJU ICPC Team decided to BG everyone!

Zoj 3947 Very Happy Great BG【水】_第1张图片

After a brief discussion, they decided to go to Lou Wai Lou to have a great dinner. Each team member can bring some friends with him/her. Of course, they need to tell the coach the number of friends they will bring.

Now the coach wants to know the total number of participants (excluding the coach himself). Please tell him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 40) - the number of ZJU ICPC members.

The second line contains N non-negative integers, the i-th integer indicates the number of friends (< 1000) that the i-th team member will bring.

Output

For each test case, output the total number of participants.

Sample Input

4
5
0 0 1 2 3
1
0
10
1 2 3 4 5 6 7 8 9 10
2
5 3

Sample Output

11
1
65
10
Author:  DAI, Longao
Source:  The 13th Zhejiang Provincial Collegiate Programming Contest


水题+1,统计输入的个数和,再加上n,即为所求


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,sum=0;
		scanf("%d",&n);
		for(int i=0;i<n;++i)
		{
			int a;
			scanf("%d",&a);
			sum+=a;
		}
		printf("%d\n",sum+n); 
	}
	return 0;
} 



你可能感兴趣的:(Zoj 3947 Very Happy Great BG【水】)