poj3461 Oulipo(KMP)

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a textT, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

大意:找出模式串在原串的出现次数。

#include<iostream>
#include<cstring>
#include<stdio.h>

using namespace std;
char str[1002000];
char temp[10200];
int Next[10200],L,l,coun;

void getnext()
{
    int i=0,j=-1;
    Next[0]=-1;
    while(i<l)
    {
         if(j==-1||temp[j]==temp[i])
               Next[++i]=++j;
          else
          {
               j=(temp[j]==temp[Next[j]])?Next[Next[j]]:Next[j];
          }
    }
}
void  KMP(int start)
{
     int i=start,j=0;
     while(i<=L)
     {
         while(j>=0&&temp[j]!=str[i])
         {
             j=Next[j];
         }
         if(j==l-1)
         {
             coun++;
             i++;
             j=Next[j+1];
         }
         else
         {
             j++;
             i++;
         }
     }
     return ;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%s",temp);
       scanf("%s",str);
       l=strlen(temp);
       L=strlen(str);
       getnext();
       coun=0;
       KMP(0);
       printf("%d\n",coun);
    }
}

KMP的稍加改变,原来返回匹配处的位置 i-j+1 ,而这道题是求出匹配次数,如果每次按返回位置的下个位置开始重新KMP,依然TLE,所以要换个策略。

应当匹配成功后,coun++,然后视作下个位置匹配失败,继续匹配,减少模板串回溯长度,节约时间。





你可能感兴趣的:(C++,算法,KMP,ACM)