Hdu 2795 Billboard

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16576    Accepted Submission(s): 7003


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
   
   
   
   
3 5 5 2 4 3 3 3
 

Sample Output
   
   
   
   
1 2 1 3 -1
 
大意:就是一个广告牌放广告,从上到下,从左到右,问广告放在第几层;

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#define lson l,m,x<<1
#define rson m+1,r,x<<1|1
using namespace std;
#define Size 200010
int tree[Size<<2],h,w,n,wid;
void MAX(int x){
	tree[x]=max(tree[x<<1],tree[x<<1|1]);
}
void build(int l, int r, int x){
	tree[x]=w;
	if(l==r)
	return;
	int m=(l+r)>>1;
	build(lson);
	build(rson);
}

int merage(int l,int r,int x){
	if(l==r) {
		tree[x]-=wid;           //找到应该贴的位置
		return l;               //返回广告所在层
	}
	int m=(l+r)>>1,ret;
	if(tree[x<<1]>=wid)
	ret=merage(lson);
	else
	ret=merage(rson);
	MAX(x);                    //查询完毕,更新整棵树
	return ret;                //返回最大值所在层
}
int main()
{
	while(cin>>h>>w>>n) 
	{
		if(h>n)	
		h=n;                   //广告牌高度最大为n 
		build(1, h, 1);
		while(n--) {
			scanf("%d",&wid);
			if(tree[1]<wid)
            printf("-1\n");    //最大值都小于这个广告的宽度,放不下输出-1
			else
			printf("%d\n",merage(1, h, 1));
		}
	}
	return 0;
}


你可能感兴趣的:(Hdu 2795 Billboard)