2010 Asia Fuzhou Regional Contest 之 Selecting courses

Selecting courses

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 62768/32768 K (Java/Others)
Total Submission(s): 2622    Accepted Submission(s): 717


Problem Description
    A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available during the time interval (A i,B i). That means, if you want to select the ith course, you must select it after time Ai and before time Bi. Ai and Bi are all in minutes. A student can only try to select a course every 5 minutes, but he can start trying at any time, and try as many times as he wants. For example, if you start trying to select courses at 5 minutes 21 seconds, then you can make other tries at 10 minutes 21 seconds, 15 minutes 21 seconds,20 minutes 21 seconds… and so on. A student can’t select more than one course at the same time. It may happen that no course is available when a student is making a try to select a course 

You are to find the maximum number of courses that a student can select.

 

Input
There are no more than 100 test cases.

The first line of each test case contains an integer N. N is the number of courses (0<N<=300)

Then N lines follows. Each line contains two integers Ai and Bi (0<=A i<B i<=1000), meaning that the ith course is available during the time interval (Ai,Bi).

The input ends by N = 0.

 

Output
For each test case output a line containing an integer indicating the maximum number of courses that a student can select.
 

Sample Input
   
   
   
   
2 1 10 4 5 0
 

Sample Output
   
   
   
   
2


贪心+暴力

把每门课按结束时间从小到大排序,结束时间相同按开始时间从小到大排序,这样按顺序选一定是最优的。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int vis[500];
struct road{
    int s,e;
}a[500];
int cmp(const road x,const road y){
    if(x.e==y.e)    return x.s<y.s;
    return x.e<y.e;
}
int main()
{
    int n;
    while(~scanf("%d",&n)){
        if(n==0)    break;
        for(int i=0;i<n;i++)
            scanf("%d%d",&a[i].s,&a[i].e);
        sort(a,a+n,cmp);
        int ans=0;
        for(int k=0;k<5;k++){
            int temp=0;
            memset(vis,0,sizeof(vis));
            for(int i=k;i<=a[n-1].e;i+=5){
                for(int j=0;j<n;j++){
                    if(vis[j])  continue;
                    if( i >= a[j].s && i < a[j].e){
                        vis[j]=1;
                        temp++;
                        break;
                    }
                }
            }
            ans=max(ans,temp);
        }
        printf("%d\n",ans);
    }
    return 0;
}



你可能感兴趣的:(HDU,2010,贪心)