HDU 2099

Description

一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?
 

Input

输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
 

Output

对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
 

Sample Input

      
      
      
      
200 40 1992 95 0 0
 

Sample Output

      
      
      
      
00 40 80 15
 
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cstdlib>

using namespace std;

int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		if(n==0&&m==0)
			break;
			int k=0;
		for(int i=0;i<10;i++)
			for(int j=0;j<10;j++)
		{
			int nn=i*10+j;
			if((n*100+nn)%m==0)
			{
				if(k==0)
					k=1;
				else
				printf(" ");
				printf("%d%d",i,j);
			}
		}
		printf("\n");
	}
}


你可能感兴趣的:(HDU 2099)