数数字

 数数字
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Submit  Status  Practice  UVA 1225
Appoint description:  jehad  (2013-09-12)System Crawler  (2016-04-22)

Description

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N(1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is: 

12345678910111213 

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program. 

Input 

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets. 

For each test case, there is one single line containing the number N . 

Output 

For each test case, write sequentially in one line the number of digit 0, 1,...9 separated by a space. 

Sample Input 

2 
3 
13

Sample Output 

0 1 1 1 0 0 0 0 0 0 
1 6 2 2 1 1 1 1 1 1


本体的解题思路是,定义一个string类型的vector向量容器,把数字转换成字符串,然后把字符串添加到向量中,然后迭代vector向量,遍历向量中的每一个string。定义一个整型数组,这里采用了一个小技巧,整型数组的下标就分别对应着0~9的数,a[i]保存i出现的次数。

#include <vector>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <stdio.h>
#include <iostream>
#include <sstream>
using namespace std;

int a[10];

//数字转字符串
string num2str(int i)
{
    stringstream ss;
    ss<<i;
    return ss.str();
}

int main(int argc, const char * argv[]) {
    
    int n;
    vector<string> v;
    cin >> n;
    while (n--) {
        int m;
        cin >> m;
        string s;
        for (int i = 1; i <= m; i++) {
            s = num2str(i);  //数字转字符串
            v.push_back(s);  //把转换后得到的字符串放到string类型的向量中
        }
        vector<string>::iterator it;   //定义迭代器
        for (it = v.begin(); it != v.end(); it++) {
            s = *it;
            for (int i = 0; i < s.length(); i++) {
                a[s[i] - 48]++;
            }
        }
        for (int i = 0; i <= 9; i++) {
            if (i == 9) {
                cout << a[i] << endl;
            } else {
                cout << a[i] << " ";
            }
        }
        v.clear();  //清空向量
        memset(a, 0, sizeof(a));  //清空数组
    }

    return 0;
}























你可能感兴趣的:(数数字)