HDU 1301 Jungle Roads

Problem Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst offoreign aid money was spent on extra roads between villages some years ago. Butthe jungle overtakes roads relentlessly, so the large road network is tooexpensive to maintain. The Council of Elders must choose to stop maintainingsome roads. The map above on the left shows all the roads in use now and thecost in aacms per month to maintain them. Of course there needs to be some wayto get between all the villages on maintained roads, even if the route is notas short as before. The Chief Elder would like to tell the Council of Elderswhat would be the smallest amount they could spend in aacms per month tomaintain roads that would connect all the villages. The villages are labeled Athrough I in the maps above. The map on the right shows the roads that could bemaintained most cheaply, for 216 aacms per month. Your task is to write aprogram that will solve such problems.

The input consists of one to 100 data sets, followed by a final line containingonly 0. Each data set starts with a line containing only a number n, which isthe number of villages, 1 < n < 27, and the villages are labeled with thefirst n letters of the alphabet, capitalized. Each data set is completed withn-1 lines that start with village labels in alphabetical order. There is noline for the last village. Each line for a village starts with the villagelabel followed by a number, k, of roads from this village to villages withlabels later in the alphabet. If k is greater than 0, the line continues withdata for each of the k roads. The data for each road is the village label forthe other end of the road followed by the monthly maintenance cost in aacms forthe road. Maintenance costs will be positive integers less than 100. All datafields in the row are separated by single blanks. The road network will alwaysallow travel between all the villages. The network will never have more than 75roads. No village will have more than 15 roads going to other villages (beforeor after in the alphabet). In the sample input below, the first data set goeswith the map above.

The output is one integer per line for each data set: the minimum cost in aacmsper month to maintain a road system that connect all the villages. Caution: Abrute force solution that examines every possible set of roads will not finishwithin the one minute time limit.

 

Sample Input

9

A 2 B 12 I 25

B 3 C 10 H 40 I 8

C 2 D 18 G 55

D 1 E 44

E 2 F 60 G 38

F 0

G 1 H 35

H 1 I 35

3

A 2 B 10 C 40

B 1 C 20

0

 

Sample Output

216

30

 

 

题目简介:某些村庄之间有路相连,现在要拆除多余的道路是所有村庄形成一个最小生成树,使得保养费最小。

方法:最小生成树。

 

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int n, sum, k;
int set[100];

struct load
{
	int u, v, w;
}num[2000];

int cmp(const void *a,const void *b)
{
	struct load *c,*d;
	c = (struct load *)a;
	d = (struct load *)b;
	return c->w - d->w;
};

int root( int x )
{
	if(set[x] == x)
		return x;
	return set[x] = root( set[x] );
};

int main()
{
	int i, j, t, m, x, y;
	char a, b;
	while(scanf("%d",&n)!=EOF,n)
	{
		memset(num,0,sizeof(num));
		for(i = 0;i<n;i++)
		{
			set[i] = i;
		}//初始化并查集
		for(i = 0,k = 0;i<n-1;i++)
		{
			scanf("%s%d",&a, &m);
			for(j = 0;j<m;j++)
			{
				scanf("%s%d",&b, &t);
				num[k].u = a - 'A';
				num[k].v = b - 'A';
				num[k].w = t;//记录每条路的两个点以及其边权
				k++;
			}
		}
		//处理
		qsort(num,k,sizeof(num[0]),cmp);//对边权进行排序
		sum = 0;
		for(i=0;i<k;i++)
		{
			x = root(num[i].u);
			y = root(num[i].v);
			if(x!=y)
			{
				sum+=num[i].w;
				set[x] = y;
			}
		}

		printf("%d\n",sum);
	}
	system("pause");
	return 0;
}


 

你可能感兴趣的:(HDU 1301 Jungle Roads)