Pat(Advanced Level)Practice--1096(Consecutive Factors)

Pat1096代码

题目描述:

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7

AC代码:
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#define MAXN 50

using namespace std;

int main(int argc,char *argv[]){
	long long n;
	long long max=0;
	long long start=0;
	long long temp;
	long long j;
	scanf("%lld",&n);
	for(long long i=2;i*i<=n;i++){
		temp=n;
		for(j=i;j<=temp;j++){
			if(temp%j==0){
				temp/=j;
			}else{
				break;
			}
		}
		if(max<j-i){
			max=j-i;
			start=i;
		}
	}
	if(max!=0){
		printf("%lld\n",max);
		for(long long i=0;i<max;i++){
			printf("%lld",start);
			start++;
			if(i!=max-1){
				printf("*");
			}
		}
		printf("\n");
	}else{
		printf("1\n%lld\n",n);
	}
	return 0;
}

奇怪!换成int类型,最后一个case超时!

你可能感兴趣的:(pat,advance)