hdu5510-沈阳区域赛 Bazinga【KMP】

题意:1~n个字符串,输出那个不包含前面所有字串的最大的编号,KMP+剪枝就能解决,主要是判断前一个和后一个的关系,如果可以包含,就不需要重复判断,否则容易超时



Bazinga

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 214    Accepted Submission(s): 89


Problem Description
Ladies and gentlemen, please sit up straight.
Don't tilt your head. I'm serious.
hdu5510-沈阳区域赛 Bazinga【KMP】_第1张图片
For  n given strings S1,S2,,Sn, labelled from 1 to n, you should find the largest i (1in) such that there exists an integer j (1j<i) and Sj is not a substring of Si.

A substring of a string Si is another string that occurs in Si. For example, ``ruiz" is a substring of ``ruizhang", and ``rzhang" is not a substring of ``ruizhang".
 

 

Input
The first line contains an integer  t (1t50) which is the number of test cases.
For each test case, the first line is the positive integer n (1n500) and in the following n lines list are the strings S1,S2,,Sn.
All strings are given in lower-case letters and strings are no longer than 2000 letters.
 

 

Output
For each test case, output the largest label you get. If it does not exist, output  1.
 

 

Sample Input
4 5 ab abc zabc abcd zabcd 4 you lovinyou aboutlovinyou allaboutlovinyou 5 de def abcd abcde abcdef 3 a ba ccc
 

 

Sample Output
Case #1: 4 Case #2: -1 Case #3: 4 Case #4: 3
代码:
#include<stdio.h>
#include<math.h>
#include<iostream>
#include<string.h>
#include<algorithm>
int nextx[2006];
char s[505][2006];
void getNext(char *str)
{
    int m = strlen(str);
    nextx[0] = nextx[1] = 0;
    for(int i = 1 ; i < m ; i ++)
    {
        int j = nextx[i];
        while(j&&str[i]!=str[j])
            j = nextx[j];
        nextx[i+1] = str[i] == str[j]?j+1:0;
    }
}
int find(char *text,char *pattern)
{
    memset(nextx,0,sizeof(nextx));
    getNext(pattern);
    int n = strlen(text);
    int m = strlen(pattern);
    int j = 0;
    for(int i = 0 ; i < n ;i++)
    {
        while(j&&pattern[j]!=text[i])
            j = nextx[j];
        if(pattern[j]==text[i])
            j++;
        if(j == m)
            return 1;
    }
    return 0;
}
int a[505];
using namespace std;
int main()
{
    int T;
    int n;
    int k = 1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        int flag = 0;
        for(int i = 1 ; i <= n ; i++)
        {
            scanf("%s",s[i]);
        }
        for(int i = 1 ; i < n ; i++)
        {
            a[i] = find(s[i+1],s[i]);
        }
        for(int i = n ; i > 1 ; i--)
        {
            for(int j = i-1 ; j >= 1 ; j--)
            {
                if(a[j]==0)
                {
                    if(!find(s[i],s[j]))//s[j]没有在s[i]中出现
                    {
                        flag = i;
                        break;
                    }

                }
            }
            if(flag!=0)
                    break;
        }
        if(flag==0)
            cout<<"Case #"<<k++<<": -1"<<endl;
        else
            cout<<"Case #"<<k++<<": "<<flag<<endl;
    }
    return 0;
}


你可能感兴趣的:(hdu5510-沈阳区域赛 Bazinga【KMP】)