HDU 2199 Can you solve this equation?

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


Sample Input
2
100

-4

Sample Output
1.6152
No solution!


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
double fun(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
       double n;
       scanf("%lf",&n);
       if (fun(0)>n||fun(100)<n)
       {
           printf("No solution!\n");
           continue;
       }
        double s=0,e=100,mid;
        mid=(s+e)/2;
        while (fabs(fun(mid)-n)>1e-5)
        {
            if (fun(mid)>n)
                e=mid-1;
            else
                s=mid+1;
            mid=(s+e)/2;
            //printf("%.4lf %.4lf %.4lf\n",s,e,mid);
             //功能很强大呀,以前一直陷在误区里面,觉得加1减1怎么能控制好精确度呢,现在突然发现这很神奇
        }
        printf("%.4lf\n",mid);
    }
    return 0;
}







你可能感兴趣的:(HDU 2199 Can you solve this equation?)