HDU1789:Doing Homework again 【贪心】

Doing Homework again

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 42   Accepted Submission(s) : 30
Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
   
   
   
   
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
   
   
   
   
0 3 5
 


AC-code:

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;

struct sc
{
	int day,score;
}num[1005];

bool cmp(sc a,sc b)
{
	if(a.score==b.score)
		return a.day<b.day;
	else return a.score>b.score;
}
int visited[1005];
int main()
{
	int T,sum,n,i,j;
	scanf("%d",&T);
	while(T--)
	{
		memset(visited,0,sizeof(visited));
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&num[i].day);
		for(i=0;i<n;i++)
			scanf("%d",&num[i].score);
		sort(num,num+n,cmp);
		sum=0;
		for(i=0;i<n;i++)
		{
			j=num[i].day;<span class="comment">// 从截止时间开始往前推,如果有一天没用过,这一天就做这一门课,这门课不扣分 </span><span> </span>
			while(j)
			{
				if(!visited[j])
				{
					visited[j]=1;
					break;
				}
				j--;
			}
			if(j==0)<span class="comment">//如果j=0,表明从time往前的每一天都被占用了,这门课完不成 </span><span> </span>
				sum+=num[i].score;
		}
		printf("%d\n",sum);
	}
	return 0;
}


 

你可能感兴趣的:(C++,HDU,贪心)