poj-2960 S-Nim (博弈SG)

S-Nim
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 3058   Accepted: 1622

Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
  • The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
  • The players take turns chosing a heap and removing a positive number of beads from it.
  • The first player not able to make a move, loses.
Arthur and Caroll really enjoyed playing this simple game until they 
recently learned an easy way to always be able to find the best move:
  • Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
  • If the xor-sum is 0, too bad, you will lose.
  • Otherwise, move such that the xor-sum becomes 0. This is always possible.
It is quite easy to convince oneself that this works. Consider these facts:
  • The player that takes the last bead wins.
  • After the winning player's last move the xor-sum will be 0.
  • The xor-sum will change after every move.
Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win. 

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S = {2, 5} each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it? 

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

Input

Input consists of a number of test cases. 
For each test case: The first line contains a number k (0 < k ≤ 100) describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. 
The last test case is followed by a 0 on a line of its own.

Output

For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. 
Print a newline after each test case.

Sample Input

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

Sample Output

LWW
WWL


思路:

       博弈论,SG函数解决;

       先说公式:sg(x) = mex{ g(y) | y是x的后继 };mex表示最小的不属于这个集合的非负整数。例如mex{0,1,2,4}=3、mex{2,3,5}=0。

       其实,一个点的SG值就是一个不等于它的 后继点的SG 的且 >=0 的最小整数。

       求SG值的过程,就是一个递归搜索的过程,比如在本题中,假如每次只能2个或3个或5个,那么6节点的后继结点有4,3,1三个,所以sg[6] = mex{sg[4] + sg[3]  + sg[1]}; 如果sg[4]还未知的话,再将其深搜求解,最终便可得到sg[6]的值!

       SG应用的场景:
           1、游戏有两个人参与,二者轮流做出决策。且这两个人的决策都对自己最有利。
           2、当有一人无法做出决策时游戏结束,无法做出决策的人输。无论二者如何做出决策,游戏可以在有限步内结束。
           3、游戏中的同一个状态不可能多次抵达。且游戏不会有平局出现。
           4、任意一个游戏者在某一确定状态可以作出的决策集合只与当前的状态有关,而与游戏者无关。


代码:

#include <stdio.h>
#include <string.h>
#define N 10010

int n;
int num[110];
int sg[N];
bool hash[110];

int getSG(int k)
{
	if(sg[k] != -1)
		return sg[k];

	memset(hash, 0, sizeof(hash));
	for(int i = 0; i < n; i ++){
		if(num[i] <= k){
			sg[k - num[i]] = getSG(k - num[i]);
			hash[ sg[k - num[i]] ] = 1;
		}
	}

	for(int j = 0; ; j ++)
		if(hash[j] == 0)
			return j;
}

int main()
{
	int i, loop;
	while(scanf("%d", &n), n){
		for(i = 0; i < n; i ++)
			scanf("%d", &num[i]);

		memset(sg, -1, sizeof(sg));			// 求SG函数
		sg[0] = 0;
		for(i = 1; i < N; i ++)
			sg[i] = getSG(i);
		
		scanf("%d", &loop);
		while(loop --){
			int m, ans = 0, ls;
			scanf("%d", &m);
			for(i = 0; i < m; i ++){
				scanf("%d", &ls);
				ans ^= sg[ls];
			}
			if(ans)
				printf("W");
			else
				printf("L");
		}
		printf("\n");	
	}

	return 0;
}


你可能感兴趣的:(博弈,sg函数)