E - Hangover(1.4.1)

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.


E - Hangover(1.4.1)_第1张图片

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)
#include <iostream>
using namespace std;
#define delta 1e-8
#define MAX 300
int main()
{
    double len[MAX];
    int total,l,r,mid;
    double x;
    len[0] = 0.0;
    for(total=1;(len[total-1]-5.20)<-delta;total++)
        len[total] = len[total-1] + 1.0/(total+1);   //直接计算出截止长度不超过5.20所需最少卡片数

    while(cin>>x&&x>delta)
    {
        l = 0,r = total;
        while((l+1)<r)         //二分查找
        {
            mid = (l+r)/2;
            if((len[mid]-x)<-delta)
                l = mid;
            else
                r = mid;
        }
        cout<<r<<" card(s)"<<endl;  //输出至少伸出x长度最少卡片数
    }
    return 0;
}


你可能感兴趣的:(数据结构,C++,Hangover1.4.1)