Power Strings
Time Limit: 3000MS |
|
Memory Limit: 65536K |
Total Submissions: 33595 |
|
Accepted: 13956 |
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source
Waterloo local 2002.07.01
#include<stdio.h>
#include<string.h>
int next[1000001], l;
char s[1000001];
void getnext()
{
next[0] = -1;
int i = 0, j = -1;
while(i < l)
{
if(j == -1 || s[i] == s[j])
{
i++;
j++;
next[i] = j;
}
else
j = next[j];
}
}
int main()
{
int i, j, k;
while(scanf("%s", s) != EOF)
{
if(s[0] == '.')
break;
l = strlen(s);
getnext();
if(l%(l-next[l]) == 0 && l/(l-next[l]) > 1)
printf("%d\n", l/(l-next[l]));
else
printf("1\n");
}
return 0;
}
题意:求出字符串的字串最大循环周期。
思路:用KMP算法求出next数组的值,接着就是判断其循环字串的长度是否能被l整除且结果不等于1.
体会:运用的是对KMPnext数组的理解,即i-next[i]即为循环字串的长度。