【并查集】HDU1213How Many Tables【模板题】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
   
   
   
   
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
   
   
   
   
2 4

代码:

#include<iostream>
#include<algorithm>
using namespace std;
int pre[1050];  //  记录父节点;
int Find(int a)     //  查找根父节点,并压缩;
{
    int t=a;
    while(pre[t]!=t) t=pre[t];      //  t保存为根父节点;
    int k=a;
    while(k!=pre[k]){       //  将所有的子节点直接连接在根父节点下;
        pre[k]=t;
        k=pre[k];
    }
    return t;
}
int n,m,a,b;
int main()
{
    int t;
    cin.sync_with_stdio(false);
    cin>>t;
    while(t--){
        cin>>n>>m;
        for(int i=1;i<1010;i++) pre[i]=i;
        for(int i=0;i<m;i++){
            cin>>a>>b;
            int x=Find(a);
            int y=Find(b);
            if(x!=y)        //  a,b属于集合,合并;
                pre[x]=y;
        }
        int ans=0;
        for(int i=1;i<=n;i++)
            if(pre[i]==i) ans++;
        cout<<ans<<endl;
    }
    return 0;
}


你可能感兴趣的:(【并查集】HDU1213How Many Tables【模板题】)