UVA 10420 List of Conquests

B - List of Conquests
Time Limit:3000MS    Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina,il catalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000 lines, but the first. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3 
Spain Donna Elvira 
England Jane Doe 
Spain Donna Anna 

Sample Output

England 1 

Spain 2


题目解析:

这题只要求出国家有多少个,再按照国家的字典序输出就好了。


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string>
#include<stdlib.h>
using namespace std;
const int N = 3000;

string str[N];
int cmp(string a,string b) {
	if(a<b)
		return 1;
	else
		return 0;
}
int main() {
	int n;
	while(cin >> n) {
		string tmp;
		for(int i=0;i<n;i++) {
			cin>>str[i]; getchar();
			getline(cin,tmp);
		}
		sort(str,str+n,cmp);

		string strx = str[0];
		int count=0;
		for(int i=0;i<=n;i++) {
			if(str[i]==strx) {
				count++;	
			}
			else
				if(str[i] != strx) {
					cout<<strx<<" ";
					cout<<count<<endl;
					strx = str[i];
					count = 1;
				}
		}
	}
	return 0;
}


你可能感兴趣的:(list,uva,of,Conquests)