poj 2823 Sliding Window

Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 51670   Accepted: 14829
Case Time Limit: 5000MS

Description

An array of size   n  ≤ 10 6  is given to you. There is a sliding window of size   k  which is moving from the very left of the array to the very right. You can only see the   knumbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:  
The array is   [1 3 -1 -3 5 3 6 7], and   k  is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers   n  and   k  which are the lengths of the array and the sliding window. There are   n  integers in the second line.  

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.  

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

POJ Monthly--2006.04.28, Ikki


这题感觉标准的优先队列;
不过我之前做过优先队列的解法了;
所以这次就用线段树吧;
建立一个保存区间最大和最小的线段树,查询即可;

#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#define pi 3.14159265358979323846
using namespace std;
struct Point
{
    int Min;
    int Max;
}tree[5000000];
int a[10000001];
int mina[10000001];
int maxa[10000001];
void build(int p,int l,int r)
{
    if(l==r) {tree[p].Min=a[l];tree[p].Max=a[l];return;}
    int mid=(l+r)/2;
    build(p*2,l,mid);
    build(p*2+1,mid+1,r);
    tree[p].Min=min(tree[p*2].Min,tree[p*2+1].Min);
    tree[p].Max=max(tree[p*2].Max,tree[p*2+1].Max);
}

int findmin(int p,int l,int r,int x,int y)
{
    if(x<=l&&r<=y) return tree[p].Min;
    int mid=(l+r)/2;
    if(y<=mid) return findmin(p*2,l,mid,x,y);
    if(x>mid) return findmin(p*2+1,mid+1,r,x,y);
    return min(findmin(p*2,l,mid,x,mid),findmin(p*2+1,mid+1,r,mid+1,y));
}
int findmax(int p,int l,int r,int x,int y)
{
    if(x<=l&&r<=y) return tree[p].Max;
    int mid=(l+r)/2;
    if(y<=mid) return findmax(p*2,l,mid,x,y);
    if(x>mid) return findmax(p*2+1,mid+1,r,x,y);
    return max(findmax(p*2,l,mid,x,mid),findmax(p*2+1,mid+1,r,mid+1,y));
}
int main()
{
    int n,k;
    scanf("%d %d",&n,&k);
    for(int i=1;i<=n;++i)
    {
        scanf("%d",&a[i]);
    }
    build(1,1,n);
    for(int i=1;i<=n-k+1;++i)
    {
        int j=i+k-1;
        mina[i]=findmin(1,1,n,i,j);
        maxa[i]=findmax(1,1,n,i,j);
    }
    for(int i=1;i<n-k+1;++i)
        printf("%d ",mina[i]);
    printf("%d\n",mina[n-k+1]);
    for(int i=1;i<n-k+1;++i)
        printf("%d ",maxa[i]);
    printf("%d\n",maxa[n-k+1]);
    return 0;
}

你可能感兴趣的:(线段树,poj)