HDU 5665:Lucky【水】

Lucky

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 304    Accepted Submission(s): 195


Problem Description
     Chaos August likes to study the lucky numbers.

     For a set of numbers S,we set the minimum non-negative integer,which can't be gotten by adding the number in S,as the lucky number.Of course,each number can be used many times.

     Now, given a set of number S, you should answer whether S has a lucky number."NO" should be outputted only when it does have a lucky number.Otherwise,output "YES".
 

Input
     The first line is a number T,which is case number.

     In each case,the first line is a number n,which is the size of the number set.

     Next are n numbers,means the number in the number set.

    1n105,1T10,0ai109 .
 

Output
     Output“YES”or “NO”to every query.
 

Sample Input
   
   
   
   
1 1 2
 

Sample Output
   
   
   
   
NO
注意:0也是自然数
AC-code:
#include<cstdio>
int main()
{
	int T,n,flag,flag1,i;
	long long a;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		flag=flag1=0;
		for(i=0;i<n;i++)
		{
			scanf("%lld",&a);
			if(a==1)
				flag=1;
			if(a==0)
				flag1=1;
		}
		if(flag&&flag1)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
} 


你可能感兴趣的:(HDU 5665:Lucky【水】)