POJ 3723 Conscription (最大生成树,kruskal,并查集)

Conscription
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9902   Accepted: 3502

Description

Windy has a country, and he wants to build an army to protect his country. He has picked upN girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M andR.
Then R lines followed, each contains three integers xi,yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223


图有可能不联通,关键是理解题意,用没优惠之前的价格减去最大生成树即可得到答案。
参考博客: http://blog.csdn.net/y990041769/article/details/41773699

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <stack> 
#include <cstring>
#define eps 1e-8
using namespace std; 
int N, M, R;
int u[50010], v[50010], w[50010];
int p[50010], father[50010];
bool cmp(int a, int b) {
	return w[a] > w[b];
}
int find(int x)  
{  
    if(father[x]==x)  
        return x;  
    return father[x] = find(father[x]);  	//压缩路径 
} 
int kruskal() {
	int i;
	int sumd = 0;
	for(i = 0; i < R; i++) p[i] = i;
	for(i = 0; i < N + M; i++) father[i] = i;
	sort(p, p + R, cmp);
	for(i = 0; i < R; i++) {
		int e = p[i];
		int x = find(u[e]);
		int y = find(v[e]);
		if(x != y) {
			sumd += w[e];
			father[x] = y;
		}
	}
	return sumd;
}
int main() {
	int T;
	scanf("%d", &T);
	while(T--) {
		scanf("%d %d %d", &N, &M, &R);
		int i;
		int x;
		for(i = 0; i < R; i++) {
			scanf("%d %d %d", &u[i], &x, &w[i]);    //给每个点重新编号
			v[i] = N + x;
		}
		int sumd = kruskal();
		printf("%d\n", (M + N) * 10000 - sumd);
	}
	return 0;
}


你可能感兴趣的:(POJ 3723 Conscription (最大生成树,kruskal,并查集))