CodeForces 628 A. Tennis Tournament(水~)

Description
n个人比赛,每次两人比赛胜者继续败者淘汰,每局比赛两位比赛选手需要b瓶水,教练需要一瓶水,整场比赛每位选手需要p条毛巾,问整场比赛共需要多少瓶水和多少条毛巾
Input
三个整数n,b,p(1<=n,b,p<=500)
Output
输出水的瓶数和毛巾的条数
Sample Input
5 2 3
Sample Output
20 15
Solution
水题
Code

#include<cstdio>
#include<iostream>
using namespace std;
int n,b,p;
int main()
{
    while(~scanf("%d%d%d",&n,&b,&p))
    {
        p*=n,b=2*b+1;
        int num=0;
        while(n!=1)
        {
            num+=n/2;
            n=n/2+n%2;
        }
        printf("%d %d\n",num*b,p);
    }
    return 0;
}

你可能感兴趣的:(CodeForces 628 A. Tennis Tournament(水~))