hdu 1711Number Sequence(kmp模板题)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19127    Accepted Submission(s): 8218


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
   
   
   
   
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
   
   
   
   
6 -1
 

Source
HDU 2007-Spring Programming Contest

题意:给你n,m(1 <= M <= 10000, 1 <= N <= 1000000),接下来分别是长度为nm的两个数组,求第二个数组在第一个数组中最先被完全匹配的位置。

 

思路:kmp模板题.当第二个数组匹配到位置m,只要输出此时第一个数组此时的位置-m+1便可以了.


#include<bits/stdc++.h>
using namespace std;
const int maxn=1100000;
int n,m;
int pattern[maxn],s[maxn];
int Next[maxn];

void get_next(){
    int i=0,j=-1;
    Next[0]=-1;
    while(i<m){
        if(j==-1||pattern[j]==pattern[i]){
            j++,i++;
            Next[i]=j;
        }
        else
            j=Next[j];
    }
}

void Kmp(){
    int i=0,j=0,flag=0;
    while(i<n){
        if(j==-1||s[i]==pattern[j])
            i++,j++;
        else
            j=Next[j];
        if(j==m){
            printf("%d\n",i+1-m);
            flag=1;
            break;
        }
    }
    if(flag==0)
        printf("-1\n");
}

int main(){
    int _;
    scanf("%d",&_);
    while(_--){
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",&s[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&pattern[i]);
        get_next();
        Kmp();
    }
    return 0;
}


你可能感兴趣的:(hdu 1711Number Sequence(kmp模板题))